1
Forum Settings
       
« Previous 1 2
Reply To Thread

Problem with Logitech Gamepad, please help!Follow

#1 Feb 23 2009 at 8:25 PM Rating: Decent
13 posts
I am attempting to use a Logitech Dual Action gamepad, but whenever I open the FFXI gamepad config tool to set it up, it doesn't respond. The PC recognizes it, and the software that came with the gamepad recognizes the keypresses during the calibration process, but when I get into the FFXI config tool, the key presses do nothing.
I have tried this on a Laptop with Win XP, a Desktop with Win Vista, and had no luck, so I bought a new copy of the controller, since mine was a year or two old, thinking that might be the problem, and the brand new gamepad (which I will be returning tomorrow) behaves in an identical fashion. I would buy a PSX to USB controller, but they aren't available in my area. If I absolutely must, I'll order one online, but I'd like to get this gamepad working if possible. Does anyone have any experience with this issue? Please help!
#2 Feb 23 2009 at 9:01 PM Rating: Excellent
22 posts
This may or may not work for you but try closing the logitech program completely. It may be causing the issue.

I have used logitech controllers exclusively for my PC and never had an issue with any of them, i just used the default drivers (plug and play) and not the logitech program.
#3 Feb 23 2009 at 9:08 PM Rating: Decent
13 posts
Yeah, I tried to list everything I tried, but I guess I forgot this - I also tried with and without the program - open, installed, in the room, you name it. ><
#4 Feb 23 2009 at 9:18 PM Rating: Good
Sage
**
628 posts
Did you check the Enable Gamepad option in the FFXI Gamepad Configuration Tool? I just bought one of those controllers last week, and that was only thing special I had to do with it after I installed the drivers from the disk.
#5 Feb 23 2009 at 9:43 PM Rating: Good
***
1,892 posts
There's an option "Enable hats or something" I honestly forget. If it's the same one as I bought on the weekend, you have to enable this (it's the 2nd option of 3 under enable gamepad). Then go in and calibrate the dual analogue sticks and gamepad.

Edited, Feb 24th 2009 5:44am by Argonaut
____________________________
Lakshmi: ZM4 & Beyond - Lakshmi: To sky - The 22 hour battle

Never Forget!
#6 Feb 24 2009 at 9:29 AM Rating: Decent
13 posts
Thank you for your help, though I do already have both of those options enabled. If anyone has experience with this specific problem, I'm still having trouble. I am trying to get it working on two computers - one for me, and one for my wife, and I cannot get the dual action to work on either of them. I have, however, gotten a PS2 controller and usb adapter to work in the gamepad config tool, but when I logged in, it didn't work. I'll post again if anything changes.
#7 Feb 24 2009 at 9:34 AM Rating: Good
Sage
**
756 posts
Make sure you're in digital mode; analog mode makes ffxi upset.
____________________________
I think you've been smoking the Moko...
http://na.finalfantasyxiv.com/lodestone/character/350413/
http://na.finalfantasyxiv.com/lodestone/character/1628942/
http://www.nerdist.com/
Angus of Cerberus (retired)
#8 Feb 24 2009 at 9:46 AM Rating: Decent
AngusX wrote:
Make sure you're in digital mode; analog mode makes ffxi upset.

^ ^ ^ ^

I got a ps2 controller and USB adaptor and was having trouble with the game recognizing it, until I realized that I forgot you have to push the digital/analog button on the gamepad to make it work. It's that simple!
____________________________
FFXIV - Neo Geo (formerly Droxy Durango)
FFXI - Brit *Manly man on the Fairy server*
{Retired for good in 2010 after the server transfer and forced name change)

#9 Feb 24 2009 at 9:53 AM Rating: Decent
**
548 posts
Use the Street Fighter IV arcade stick. It's the coolest.
____________________________
MUTED
#10 Feb 24 2009 at 10:15 AM Rating: Decent
13 posts
When you say
"Make sure you're in digital mode"
You mean try it with the little light in the middle of the controller OFF? Ok, I'll try that. One moment.
#11 Feb 24 2009 at 10:18 AM Rating: Decent
13 posts
No dice. I gather that isn't what you meant... I read your comment and the one after yours and desperately hoped it could be fixed that easily. Now I recall that the button in the middle only activates/deactivates the analog sticks... which I want on, of course. I think I recall having this problem before though, now that you mention it... how DO you switch to digital mode? Where is that option?
#12 Feb 24 2009 at 10:20 AM Rating: Decent
Scholar
****
4,559 posts
Did you install the software for the gamepad? Is there a W in your system tray?
#13 Feb 24 2009 at 10:36 AM Rating: Decent
13 posts
I tried using the gamepad WITH the software installed AND without it. Are you suggesting one method or the other is more likely to work? Everything I saw said not to bother with the software, that plug and play would work fine. I'll be more than happy to try whatever might resolve this, though... we took a break for a year or so and we're eager to return.
#14 Feb 24 2009 at 10:37 AM Rating: Good
Sage
**
756 posts
yes, I was referring to the button in the middle with the light. IDK why you're having trouble. Have you checked the gamepad setting in Windows Control Panel? I can tell you that the gamepad software is not necessary to operate the pad.
____________________________
I think you've been smoking the Moko...
http://na.finalfantasyxiv.com/lodestone/character/350413/
http://na.finalfantasyxiv.com/lodestone/character/1628942/
http://www.nerdist.com/
Angus of Cerberus (retired)
#15 Feb 24 2009 at 10:40 AM Rating: Decent
13 posts
Ok, I can check that, but what am I checking? brb, afk for about 10 minutes. Thank you all so much for trying to help.
#17 Feb 24 2009 at 11:19 AM Rating: Decent
13 posts
Thanks, I'll try that! give me a few minutes...
#18 Feb 24 2009 at 11:49 AM Rating: Decent
13 posts
Enabling Gamepad in Playonline Viewer Config didn't help. Any other suggestions? ^.^;;
#19 Feb 24 2009 at 12:37 PM Rating: Good
Sage
**
756 posts
I'm running out of ideas. What happens when you click the Test Gamepad button in FFXI Config? Also, are you running in windowed mode (or Windower)?
____________________________
I think you've been smoking the Moko...
http://na.finalfantasyxiv.com/lodestone/character/350413/
http://na.finalfantasyxiv.com/lodestone/character/1628942/
http://www.nerdist.com/
Angus of Cerberus (retired)
#21 Feb 24 2009 at 1:31 PM Rating: Decent
13 posts
That's the problem exactly - the gamepad config window is NOT recognizing the button presses, either when setting movement/camera/menu controls or the basic commands, such as confirm or cancel. In the case of the PSX/USB converter, I am able to config the gamepad (the config tool DOES recognize the button presses), but once I get into the game, the gamepad does nothing.

@AngusX: Nothing happens when I hit test gamepad and try out some button presses, since I am unable to bind the commands/movement/camera/etc to anything on the game pad. Even if I bind it MANUALLY, though, by looking to see which button is which, the "Test gamepad" window still doesn't respond. (in the case of the converter, every part of the config tool, including the test window, recognizes the input from the PS2 controller, but the game itself does not.

These circumstances hold true in both XP, Vista, with software installed, without it, with gamepad checked in POL config, without it, and everything else I can think of to try. I'm missing something... What did you mean when you asked me to make sure I was in digital mode, AngusX? Did I cover that already?
#22 Feb 24 2009 at 1:47 PM Rating: Decent
13 posts
Oh, and since someone asked: No, I am not running in any form of windowed mode. I am running in fullscreen.
#23 Feb 24 2009 at 1:55 PM Rating: Good
Sage
**
756 posts
I think we covered the digital mode button. If that was the case, once you logged in, your camera view starts spinning around the room. It doesn't sound like that's happening to you. Sorry, I'm all out of ideas now. :(
____________________________
I think you've been smoking the Moko...
http://na.finalfantasyxiv.com/lodestone/character/350413/
http://na.finalfantasyxiv.com/lodestone/character/1628942/
http://www.nerdist.com/
Angus of Cerberus (retired)
#24 Feb 24 2009 at 2:04 PM Rating: Decent
13 posts
Ok, I'm going to log in and ask in Jeuno or some such. Thanks for trying to help, everyone, and I probably will keep checking back - only got any real back-and-forth here (out of the three forums I asked), so I'm hoping someone will come up with something.
#25 Feb 24 2009 at 4:10 PM Rating: Decent
13 posts
Well, not much help in Jeuno or Whitegate... I don't know where else to look :-/ Anyone know of a place where I might be able to get live support? i.e. some sort of chat for this kind of thing? I'm grasping at straws now...
#26 Apr 26 2017 at 1:41 PM Rating: Decent
4 posts
HEY! To get the config tool to work with your controller you should run the config tool as administrator. This allowed me to set all the buttons. HOWEVER **** You may run into the same issue afterwards that I am currently working on. Controller will work fine all the way up to in game and then the camera will just spin. Unfortunately at the time of this post I have been unable to troubleshoot this problem. But will check back and post any findings for you.
Necro Warning: This post occurred more than thirty days after the prior, and may be a necropost.
« Previous 1 2
Reply To Thread

Colors Smileys Quote OriginalQuote Checked Help

 

Recent Visitors: 131 All times are in CST
Anonymous Guests (131)